Amaya: o editor web da W3C

O Amaya é um editor web, ou seja, uma ferramenta usada para criar e atualizar documentos diretamente na web. A principal motivação para o desenvolvimento do Amaya era fornecer uma estrutura que pudesse integrar todos os padrões da W3C. Ele é usado para demonstrar estes padrões em ação, aproveitando a sua combinação em um ambiente único e consistente.

Amaya W3C

Recursos

O Amaya começou como um editor de HTML e CSS. Foi estendido para suportar XML e um número crescente de aplicações XML, como a família XHTML, MathML e SVG. Hoje ele permite todos os vocabulários simultaneamente em documentos compostos.

amaya codes

O Amaya inclui um aplicativo de anotação colaborativa baseado em Resource Description Framework (RDF), XLink e XPointer. É um projeto de software em código aberto oferecido pela W3C. Você está convidado a contribuir de várias formas (documentação, tradução, escrita de código, correção de bugs, portar para outras plataformas…). O software é escrito em C e está disponível para Windows, Linux e MacOS X.

amaya editor

Vídeo

Segue abaixo um vídeo do Amaya em ação.

Instalação

Para instalar o Amaya você tem que visitar o site oficial em http://www.w3.org/Amaya/ e baixar o arquivo referente ao seu sistema. Atualmente há binários para Ubuntu, Debian, openSUSE, MacOS X e Windows. Caso seu sistema não seja um desses, procure no repositório da sua distribuição Linux.

Análise

O software é muito bom para pessoas que prezam por páginas em conformidade com os padrões da W3C porque ele te mostra os erros no código e os corrige. Muitos não se importam com esses padrões. Mas pelo menos os erros mais graves podem ser corrigidos com a ajuda do Amaya e os nossos navegadores agradecem. Espero que tenham gostado dessa dica. Nos ajude deixando seu comentário logo abaixo. Até a próxima e bom trabalho!

Helbert Rocha

Business & Linux Admin | Digital Mkter | Live in Rio | Love Jesus
Google+

  • Fábio
    Google Chrome 27.0.1453.93 Google Chrome 27.0.1453.93 no GNU/Linux x64 GNU/Linux x64

    Não suporta HTML 5 🙁

  • Mateus Souza
    Firefox 37.0 Firefox 37.0 no Windows 8.1 x64 Edition Windows 8.1 x64 Edition

    Prefiro o meu Sublime Text 3.