TweetDeck: guia completo para Ubuntu 64 bits

Muita gente hoje em dia prefere instalar um software para gerenciar a conta do Twitter de forma mais eficaz. Devido ao grande número de perfis interessantes para seguir, um ótimo programa para filtrar todo esse fluxo de mensagens que chegam por minuto se dá necessário. E um dos mais aclamados nesse quesito é o TweetDeck. Com o TweetDeck, você tem uma visão geral. Desde seus próprios tweets até buscas. Se você ainda não o testou, aproveite agora mesmo esse artigo, pois ele será um guia completo de instalação para Ubuntu 32/64 bits.

Instalação

Bem, o processo de instalação para 64 bits é um pouco mais complicado do que para o sistema de 32 bits. Mas por que isso? Porque o TweetDeck está disponível apenas para sistemas de 32 bits. Se você usa o Ubuntu 64 bits, terás de acrescentar mais uns passos à sua instalação. Por isso, vou ensinar como instalar para o sistema 64 bits, pois para 32 bits é só excluir os passos de instalação de bibliotecas 32 bits para o Ubuntu 64 bits (nunca escrevi tanto a palavra “bits”).

Adobe AIR

O Adobe AIR é um requisito para o TweetDeck funcionar. Devemos instalá-lo antes do TweetDeck. Para baixar o Adobe AIR, clique aqui. Será baixado um arquivo binário do instalador do Adobe AIR.

Bibliotecas/Dependências 32 bits para uso em sistema 64 bits

Essas bibliotecas são realmente muito úteis pois elas resolvem dependências que venham a ser necessárias para que um sistema 64 bits execute um aplicativo feito para 32 bits. Baixe o pacote DEB com o Getlibs aqui. Dando duplo clique nele, você o instalará.

Instalando o Adobe AIR

Após tudo isso, abra o terminal e cole (Ctrl+Shift+V) o comando abaixo na pasta onde salvou o instalador para instalar o Adobe AIR.

chmod +x AdobeAIRInstaller.bin && sudo ./AdobeAIRInstaller.bin
Será aberta uma janela para instalação do Adobe AIR. Siga as instruções.

Finalizando os ajustes

Antes de partirmos para a instalação do TweetDeck propriamente dito, devemos ainda realizar uns ajustes com o comando abaixo. Ele instalará mais algumas bibliotecas e dependências para sistemas 64 bits.

sudo apt-get install lib32asound2 lib32gcc1 lib32ncurses5 lib32stdc++6 lib32z1 libc6 libc6-i386 lib32nss-mdns && sudo getlibs -l libnss3.so.1d libnssutil3.so.1d libsmime3.so.1d libssl3.so.1d libnspr4.so.0d libplc4.so.0d libplds4.so.0d libgnome-keyring.so libgnome-keyring.so.0 libgnome-keyring.so.0.1.1 && sudo cp /usr/lib/libadobecertstore.so /usr/lib32 && sudo ldconfig

TweetDeck

Agora sim. Baixe o TweetDeck aqui e dê um duplo clique nele para se iniciar seu processo de instalação. Siga as instruções. Após o término, você pode acessar o TweetDeck em Aplicativos > Acessórios.

Atualização em 09/06/2010: Esse tutorial acima não é mais necessário. Agora, basta instalar o pacote ia32-libs para conseguir instalar o Adobe Air 1.5, e em seguida, dê duplo clique no arquivo .AIR do TweetDeck para o instalar. Após a sua instalação dê o seguinte comando: sudo cp /usr/lib/libadobecertstore.so /usr/lib32 . Pronto. Agora é só abrir o TweetDeck que ele estará funcionando.

Imagens

TweetDeck Painel
TweetDeck Colunas

Helbert Rocha

Business & Linux Admin | Digital Mkter | Live in Rio | Love Jesus
Google+

  • Gabão
    Firefox 3.5.1 Firefox 3.5.1 no Windows XP Windows XP

    Estou usando ele a algum tempo, é muito bom recomendo para todos…
    antes eu usava o twhirl que também é muito bom mas esse ai consegue superar 😛

  • Mike Metralha
    Google Chrome 5.0.375.29 Google Chrome 5.0.375.29 no GNU/Linux x64 GNU/Linux x64

    Obrigado mesmo pela dica. Desde que migrei para o Ubuntu 10.04 64 estava apanhando horrores pra botar o TweetDeck pra funcionar. Valeu mesmo!

  • Firefox 3.6.3 Firefox 3.6.3 no Ubuntu 10.04 x64 Ubuntu 10.04 x64

    Cara… valeu pelo tutorial… muito bom…
    Se vc autorizar vou postar essa solução lá no meu site também pro pessoal poder saber disso… sempre recomendo pros meus alunos usarem o ubuntu… isso vai ser uma mão na roda…

    abração

    MeuPinguim responde: Olá Felipe. Lógico que eu autorizo. Só citar a fonte e tá tudo certo. Abraço.

    • novato
      Internet Explorer 8.0 Internet Explorer 8.0 no Windows XP Windows XP

      aproveita e coloca no seu sítio como instalar e fazer rodar aplicaticos 32 bits no ubuntu 64 bits, não exigindo muito, um passo a passo de preferencia…. forte abraço.
      obs.esse site ta muito bom so que eu nao etendi nada.

  • Firefox 3.6.3 Firefox 3.6.3 no Ubuntu 10.04 x64 Ubuntu 10.04 x64

    Muito obrigado! Agora sim! AIR funcionando no Ubuntu 64 10.04 64 bits.

  • Robson
    Google Chrome 7.0.517.44 Google Chrome 7.0.517.44 no Windows Vista Windows Vista

    Eu criei uma solução brasileira parecida com o Tweetdeck que, entre outras vantagens, agrega os updates do orkut também. Ele ainda não faz tudo que o Tweet mas vai sendo aperfeiçoada a medida que eu receber feedback dos usuários.
    Se quiser testar: http://www.ontheweb.com.br/socialmenage/

  • Nielson
    Google Chrome 7.0.517.44 Google Chrome 7.0.517.44 no GNU/Linux x64 GNU/Linux x64

    Valeu pelo tutorial, mas vc poderia ter colocado o aviso que bastava instalado o pacote ia32-libs no início do tutorial ao invés de no final.

    MeuPinguim responde: Olá Nielson. Esse aviso somente está no fim do artigo por se tratar de uma atualização do artigo original. E essa informação foi acrescentada posteriormente, portanto adicionada ao fim do artigo. Entendo a sua lógica. Realmente deveria estar logo no início mas alteraria o artigo inicial que ainda pode ser útil para outrem. Obrigado e volte sempre.

  • Firefox 3.6.13 Firefox 3.6.13 no Ubuntu 10.04 x64 Ubuntu 10.04 x64

    Mais uma vez a comunidade colabora para resolver o descaso das grandes empresas com software livre, otimo tutorial, parabens!
    Só uma dúvida, ele funciona para instalar o adobe air 2.5.1 no ubuntu 10.04 64? abraços!

    MeuPinguim responde: Olá Juin. O artigo foi atualizado pois para instalar o Tweetdeck no 64 bits basta instalar o pacote ia32-libs que contém as bibliotecas de 32 bits para o sistema 64 bits. Em seguida, dê duplo clique no arquivo .AIR do TweetDeck para o instalar. Obrigado e volte sempre.

  • GuiPedr0s0
    Google Chrome 9.0.597.98 Google Chrome 9.0.597.98 no GNU/Linux GNU/Linux

    Muito Bom =D

  • Bruno Beiruth
    Google Chrome 10.0.648.151 Google Chrome 10.0.648.151 no GNU/Linux x64 GNU/Linux x64

    Meu irmão, esta sua dica me ajudou bastante. Parabéns pela sua iniciativa.

  • Firefox 4.0 Firefox 4.0 no GNU/Linux x64 GNU/Linux x64

    Parabens, otima dica. Segui o tuto e tá funcionando numa boa, o problema é que de vez em quando o bicho da uns lags feios demais, que preciso fechar e abrir novamente até parar o lag. As vezes quando uso a barra de rolagem pra navegar ele embola os tweets um por cima do outro..Não sei se o problema está no tweet deck ou no adobe air funcionando a 64 bits. Alguem mais tem esse problema ae?

  • Guilherme
    Google Chrome 13.0.782.218 Google Chrome 13.0.782.218 no GNU/Linux x64 GNU/Linux x64

    dá um erro quando tento instala ele pela pasta.
    /tmp/air.MNpIen/setup: error while loading shared libraries: libgtk-x11-2.0.so.0: wrong ELF class: ELFCLASS64

    MeuPinguim responde: ???